Service Interruption: Team Management and PowerPay
Incident Report for SportsEngine
Resolved
This issue has been resolved.
Posted 3 months ago. Mar 08, 2017 - 13:48 CST
Monitoring
Scope: Team Management and PowerPay were unavailable from 1:32pm-1:35pm CST
Next Update: 30 minutes

The issue has been resolved and we are continuing to monitor the situation.
Posted 3 months ago. Mar 08, 2017 - 13:38 CST