Degraded Functionality: E7Sports Tourney Registration is not functioning
Incident Report for SportsEngine
Resolved
This issue is fully resolved.
Posted May 13, 2016 - 16:00 CDT
Identified
Scope: We have identified the issue with E7Sports Tourney Registration and are actively working on resolving the issue.

Next Update: 30 minutes
Posted May 13, 2016 - 12:41 CDT