Degraded Functionality: Kyck player cards have an incorrect expiration date.
Incident Report for SportsEngine
Resolved
The player cards with incorrect expiration dates have been corrected. This incident is resolved.
Posted Aug 03, 2016 - 15:26 CDT
Update
There are 3700 player cards with incorrect expiration dates. These cards should have expired on 8/1/2016 but have not. We are actively working to correct the expirations and hope to have a resolution to this issue here today.
Next Update: 2 hours
Posted Aug 03, 2016 - 13:38 CDT
Identified
Scope: Some Kyck player cards have an incorrect expiration date. We have issued free player cards in the interim and are working to correct the expiration date.
Next Update: 2 hours

We are currently investigating this issue.
Posted Aug 03, 2016 - 11:26 CDT