Degraded Functionality: Registration and Power Pay MasterCard Transactions are Failing
Incident Report for SportsEngine
Resolved
MasterCard transactions are now going through successfully. This issue appeared to begin at 3:39 am CT and resolved at 8:53 am CT.
Posted 4 months ago. May 10, 2018 - 09:15 CDT
Identified
Scope: Registration and Power Pay MasterCard Transactions are Failing.
Next Update: 30 minutes

We are seeing a large number of credit card transaction failures. We have identified the issue as a MasterCard processing issue. MasterCard technical resources are working to resolve the issue.
Posted 4 months ago. May 10, 2018 - 08:58 CDT
This incident affected: SportsEngine Core Platform (Registration, PowerPay).