Service Interruption: Kyck Play is unavailable.
Incident Report for SportsEngine
Resolved
Kyck has been stable for over an hour. This issue is fully resolved.
Posted Sep 28, 2016 - 12:14 CDT
Monitoring
Kyck Play is working again. We will continue to monitor the situation.
Posted Sep 28, 2016 - 11:08 CDT
Identified
Scope: Kyck Play is unavailable. We have indentified the issue and expect to have it resolved soon.
Next Update: 5 minutes

We are currently investigating this issue.
Posted Sep 28, 2016 - 11:01 CDT