Degraded Functionality: Voting on Power Poll page elements is not working
Incident Report for SportsEngine
Resolved
Voting on Power Poll page elements is working again. This issue is resolved.
Posted Nov 07, 2016 - 12:34 CST
Identified
Scope: Voting on Power Poll page elements is not working.
Next Update: 30 minutes

We have identified the issue and are working on a fix.
Posted Nov 07, 2016 - 11:43 CST