Degraded Functionality: Dibs
Incident Report for SportsEngine
Resolved
The functionality issues with Dibs have now been resolved.
Posted Oct 13, 2016 - 10:31 CDT
Investigating
Scope: Dibs is currently experiencing degraded functionality.
Next Update: 30 minutes

We are currently investigating this issue.
Posted Oct 13, 2016 - 09:48 CDT