Degraded Functionality: SIPlay Website Creator Login Unavailable
Incident Report for SportsEngine
Resolved
We have identified and corrected the issue disrupting logins to SIPlay's Website Creator - The issue is now corrected and we will continue to monitor the fix over the coming hours.
Posted 3 months ago. Jul 03, 2018 - 18:05 CDT
Investigating
Scope: Login for SIPlay's Website Creator product is currently unavailable.
Next Update: 30 minutes

We are currently investigating this issue.
Posted 3 months ago. Jul 03, 2018 - 17:51 CDT
This incident affected: SI Play.