Degraded Functionality: SportsEngine Platform Password Reset
Incident Report for SportsEngine
Resolved
Password resets are now working properly. This issue has been resolved.
Posted Feb 15, 2017 - 19:37 CST
Update
We're still investigating the password reset issue.
Next Update: 30 minutes
Posted Feb 15, 2017 - 19:16 CST
Investigating
Scope: SportsEngine Platform password resets are currently not functioning properly.
Next Update: 30 minutes

We are currently investigating this issue.
Posted Feb 15, 2017 - 18:35 CST