Degraded Functionality: TrackWrestling Payments
Incident Report for SportsEngine
Resolved
The TrackWrestling payment issue has been resolved.
Posted 2 months ago. May 15, 2018 - 20:18 CDT
Monitoring
We have implemented a fix for the payment submission issue and are continuing to monitor the situation.
Posted 2 months ago. May 15, 2018 - 19:47 CDT
Update
We are continuing to work on a fix for the payment submission issue.

Next Update: 30 minutes
Posted 2 months ago. May 15, 2018 - 19:24 CDT
Identified
We have identified the issue and are continuing to work to resolve it.

Next Update: 1 hour
Posted 2 months ago. May 15, 2018 - 18:22 CDT
Investigating
Scope: All TrackWrestling payments are returning an error on submission.
Next Update: 30 minutes

We are currently investigating this issue.
Posted 2 months ago. May 15, 2018 - 17:43 CDT