Service Interruption: Kyck Play
Incident Report for SportsEngine
Resolved
This issue has been resolved since 10:53am CT.
Posted 4 days ago. Sep 14, 2018 - 11:07 CDT
Monitoring
Kyck Play is available again, we are continuing to monitor the situation.
Posted 4 days ago. Sep 14, 2018 - 10:59 CDT
Investigating
Scope: Kyck Play is currently unavailable.
Next Update: 30 minutes

We are currently investigating this issue.
Posted 4 days ago. Sep 14, 2018 - 10:37 CDT
This incident affected: Kyck.