Degraded Functionality: Delay in sending invoices.
Incident Report for SportsEngine
Resolved
This incident has been resolved.
Posted 25 days ago. Jan 28, 2019 - 15:32 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 25 days ago. Jan 28, 2019 - 15:00 CST
Identified
Scope: Delay in sending invoices after creation.
Next Update: 30 minutes

We've identified the issue and are releasing a fix.
Posted 25 days ago. Jan 28, 2019 - 14:32 CST
This incident affected: SportsEngine Core Platform (PowerPay).