SportsSignup Outage
Incident Report for SportsEngine
Update
Scheduled Maintenance has been completed on time without issue. All systems are now fully operational.

Although additional latency on email delivery continues, we are working to restore normal delivery times.
Posted 18 days ago. Sep 02, 2019 - 23:45 CDT
Update
We are beginning our Scheduled Maintenance. We will update once it's complete.
Posted 18 days ago. Sep 02, 2019 - 21:06 CDT
Update
Following the recent Amazon Web Server (AWS) outage on 8/31, we will be taking the SSU applications offline at 10PM ET in order to perform several platform enhancements that will provide a more dependable experience for you. We expect these updates to take between 2 and 4 hours. We will post to the status page with the result of the migration. To be clear, this will not restore potential lost data from 8/27/19 - 8/31/19. However, this will provide enhanced platform stability and correct the issue resulting in the “502 Bad Gateway” errors you may have been experiencing. In addition, you can rest assured that this maintenance will not affect any work that you have done within your system after the previous AWS outage. Thank you for your continued patience while we work to resolve this issue and provide you an improved experience.
Posted 18 days ago. Sep 02, 2019 - 16:07 CDT
Monitoring
On 8/31 at 9am ET we experienced an Amazon Web Server (AWS) outage that affected work your league may have completed on the SportsSignUp platform at the end of last week. We continue working diligently with AWS to investigate the failure, and with our engineering teams to attempt to restore admin activity data input since 8/27/19. While full functionality has been restored, at this time, we do not have confidence that full backups of admin work from 8/27/19 - 8/31/19 will be recovered. This would have impacted any teams you may have created, rosters updated, game results and stats entered and schedules updated. While registration data was impacted, we are working on a plan to rebuild that information and we will communicate those plans as quickly as possible. As a volunteer, we know how valuable your time is. We deeply apologize for this inconvenience, for the potential work lost during this period, and for the time it may take you or your club to re-complete that work. We will be working diligently to provide you additional updates over email and posts on this status page in the coming days.
Posted 19 days ago. Sep 01, 2019 - 20:45 CDT
Update
We have found and fixed the issue with email, we are continuing to assess the impact of the outage.
Posted 20 days ago. Sep 01, 2019 - 14:04 CDT
Update
While we are back up, we are currently assessing the impact the outage had on our system and affected data. Email communication is currently not working. We anticipate that this will take some additional time to work through and provide you with a better assessment and plan forward.
Posted 20 days ago. Sep 01, 2019 - 13:01 CDT
Update
Service has been restored, we will monitor the situation.
Posted 20 days ago. Aug 31, 2019 - 23:43 CDT
Update
AWS continues to work on the issue, but report they are making progress. Another update in an hour or so.
Posted 20 days ago. Aug 31, 2019 - 18:31 CDT
Update
AWS continues to work on the issue. Another update in an hour.
Posted 20 days ago. Aug 31, 2019 - 16:37 CDT
Update
AWS has more clearly identified the issue on their end, and their engineers continue to work for a resolution. We will post another update in an hour.
Posted 21 days ago. Aug 31, 2019 - 15:36 CDT
Update
A few of the other instances that were down are now back up, but the one critical instance is still down. Another update in an hour.
Posted 21 days ago. Aug 31, 2019 - 14:35 CDT
Update
No update to share yet, but we are continuing to raise the issue with AWS support. I am going to move to 60m update intervals until this is resolved.
Posted 21 days ago. Aug 31, 2019 - 13:33 CDT
Update
AWS has released an update (https://status.aws.amazon.com/). It looks like we are in the last few percent of instances to be recovered, so hopefully things will change soon. Another update in 30m.
Posted 21 days ago. Aug 31, 2019 - 13:02 CDT
Update
Our AWS team is working on prioritizing fixing that one instance, but still no change.
Posted 21 days ago. Aug 31, 2019 - 12:32 CDT
Update
We are trying to get our AWS team involved to escalate this, but no change as of right now. Update in 30m.
Posted 21 days ago. Aug 31, 2019 - 12:01 CDT
Update
No change yet, but AWS is still indicating things will eventually improve. I will update again in 30m.
Posted 21 days ago. Aug 31, 2019 - 11:33 CDT
Update
AWS continues to work on the issue, no change to our instances yet. Another update in 30m.
Posted 21 days ago. Aug 31, 2019 - 10:57 CDT
Update
AWS is reporting a fix is in progress, but no ETA on service state resolution. We continue to wait and test! 30m until next update.
Posted 21 days ago. Aug 31, 2019 - 10:26 CDT
Update
AWS is still working on the issue. No updates beyond 'please be patient'. Will report back in another 30.
Posted 21 days ago. Aug 31, 2019 - 09:49 CDT
Update
AWS has updated their end acknowledging the issue and are actively working on resolution. Our instances are still unavailable. Update in another 30m.
Posted 21 days ago. Aug 31, 2019 - 09:14 CDT
Identified
There is currently a major AWS outage that is affecting our servers, once AWS resolves their issue we will recover services ASAP. Updates every 30m!
Posted 21 days ago. Aug 31, 2019 - 08:45 CDT
This incident affects: SportsSignup Play and SportsSignup Play Mobile.