Trackwrestling payment failures
Incident Report for SportsEngine
Resolved
This incident has been resolved.
Posted Apr 15, 2019 - 17:16 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2019 - 16:57 CDT
Investigating
We are currently investigating this issue.
Posted Apr 15, 2019 - 16:45 CDT
Identified
Scope: All Trackwrestling payments are failing
Next Update: 30 minutes

We believe we have identified the issue and are implementing a fix.
Posted Apr 15, 2019 - 16:28 CDT
This incident affected: TrackWrestling.