Degraded Functionality: Team Center is experiencing degraded functionality
Incident Report for SportsEngine
Resolved
This incident has been resolved.
Posted Sep 15, 2021 - 16:14 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 15, 2021 - 12:59 CDT
Investigating
Scope: Team Center is experiencing degraded functionality
Next Update: 30 minutes

We are currently investigating this issue.
Posted Sep 15, 2021 - 12:15 CDT
This incident affected: SportsEngine Platform (Team, Mobile).