Service Interruption: League Toolbox
Incident Report for SportsEngine
Resolved
The maintenance has been completed.
Posted Sep 06, 2019 - 06:17 CDT
Identified
Some components of leaguetoolbox.com are inaccessible. Maintenance is being performed to bring the system back online.
Posted Sep 06, 2019 - 01:39 CDT
Investigating
Scope: leaguetoolbox.com and related sites are down at this time.
Next Update: 30 minutes

We are currently investigating this issue.
Posted Sep 06, 2019 - 01:07 CDT
This incident affected: League Toolbox.