SportsEngine Platform: Degraded Performance
Incident Report for SportsEngine
Resolved
The issues have been resolved.
Posted Mar 31, 2022 - 08:35 CDT
Monitoring
We are seeing performance return to normal for the SportsEngine platform. Our team will continue to monitor.
Posted Mar 31, 2022 - 08:31 CDT
Investigating
At this time, we are currently seeing some slowness across the SportsEngine platform. Our team is actively working to resolve.
Posted Mar 31, 2022 - 08:11 CDT
This incident affected: SportsEngine Platform (Registration, Sitebuilder, Invoicing, Team, Tourney, League, Background Screening, Mobile, API, Members, Sportsengine.com, HQ, MySE).