Email service disruption
Incident Report for SportsEngine
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 13:24 CDT
Investigating
TeamUnify Australia email is unavailable at the moment, we have identified the issue and are working to resolve. Next update in 30m.
Posted Jun 01, 2020 - 12:59 CDT
This incident affected: TeamUnify (SwimOffice AU).