Degraded Functionality: League Athletics Websites
Incident Report for SportsEngine
Resolved
This incident has been resolved.
Posted Dec 02, 2021 - 10:44 CST
Identified
We have identified the issue and are working to resolve it.
Posted Dec 02, 2021 - 10:06 CST
Investigating
Scope: League Athletics Websites and Registration
Next Update: 30 minutes

We are currently investigating this issue.
Posted Dec 02, 2021 - 09:59 CST
This incident affected: League Athletics.