Degraded Functionality: PowerPay Past Due Payments
Incident Report for SportsEngine
Resolved
The past due payment issue has been resolved.
Posted Jul 06, 2018 - 09:47 CDT
Identified
Scope: Paying past due invoices in PowerPay is currently unavailable.
Next Update: 30 minutes

We have identified the issue and are working to resolve it as quickly as possible.
Posted Jul 06, 2018 - 09:15 CDT
This incident affected: SportsEngine HQ (Financials - invoicing, reporting, payment processing).