Service Interruption: League Athletics login unavailable
Incident Report for SportsEngine
Resolved
This incident has been resolved.
Posted 13 days ago. Sep 07, 2019 - 20:06 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 13 days ago. Sep 07, 2019 - 19:59 CDT
Investigating
Users are unable to login to League Athletics.
Posted 13 days ago. Sep 07, 2019 - 16:58 CDT
This incident affected: League Athletics.