Service Interruption: SI Play Classic Sites, Web Creator and Mobile app
Incident Report for SportsEngine
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 18, 2019 - 15:21 CDT
Investigating
Scope: SI Play Classic sites are unavailable and Web Creator and the Mobile app are in a degraded state.
Next Update: 30 minutes

We are currently investigating this issue.
Posted 4 months ago. Mar 18, 2019 - 14:00 CDT
This incident affected: SportsSignup Play.