League Athletics: Degraded Performance
Incident Report for SportsEngine
Resolved
The issues have been resolved.
Posted Mar 30, 2022 - 11:12 CDT
Monitoring
We are seeing performance return to normal for League Athletics and will continue to monitor.
Posted Mar 30, 2022 - 11:00 CDT
Investigating
At this time, you may experience some degraded performance with League Athletics. Our team is actively engaged and investigating the issue to resolve as quickly as possible.
Posted Mar 30, 2022 - 10:26 CDT
This incident affected: League Athletics.