Degraded Functionality: Canadian Payments may not able to process
Incident Report for SportsEngine
Resolved
A fix has been implemented. All payments should be processing as normal.
Posted 12 days ago. Jul 10, 2019 - 17:59 CDT
Investigating
Scope: Canadian customers may have trouble submitting payments through one of our 3rd party payment processing companies. They are investigating the issue and are working on a fix.
Next Update: 30 minutes
Posted 12 days ago. Jul 10, 2019 - 16:29 CDT
This incident affected: SportsEngine Core Platform (PowerPay).