SE Motion U.S. - Elevated Email Delivery Failure Rates

Incident Report for SportsEngine

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 18:23 CDT

Investigating

We are currently investigating this issue.
Posted Apr 01, 2025 - 12:50 CDT
This incident affected: SportsEngine Motion (SportsEngine Motion US).