Degraded Functionality: League Athletics
Incident Report for SportsEngine
Resolved
We have implemented a fix and service is restored.
Posted Aug 30, 2021 - 08:55 CDT
Investigating
Scope: League Athletics

We are currently investigating this issue.
Posted Aug 30, 2021 - 08:35 CDT
This incident affected: League Athletics.