Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 27, 2025 - 21:00 CDT
Scheduled
SportsEngine Tourney will be undergoing system maintenance on Thursday, March 27, 2025 from 9:00pm CDT to 11:00pm CDT. During this maintenance window, access to the application will be unavailable and users will be directed to a maintenance landing page.
We apologize for any inconvenience this may cause, and thank you for your understanding as we work to improve the platform.
Posted Mar 27, 2025 - 18:47 CDT
This scheduled maintenance affected: SportsEngine Tourney (Tourney Machine).