NCSI (Background Screening): Service Interruption
Incident Report for SportsEngine
Resolved
All services have returned to normal, and the issues with background screens have been resolved for NCSI legacy customers.
Posted Jan 21, 2022 - 11:17 CST
Update
We are continuing to work on a fix for this issue.
Posted Jan 21, 2022 - 11:02 CST
Update
We are continuing to work on a fix for this issue.
Posted Jan 21, 2022 - 11:01 CST
Identified
The issue has been identified, and our engineers are continuing to diligently work on the issue. We apologize for any inconvenience this may cause for your operation.
Posted Jan 21, 2022 - 10:54 CST
Investigating
At this time, we are currently experiencing issues with processing background screens for NCSI legacy customers. We are actively working to resolve the issue.
Posted Jan 21, 2022 - 09:50 CST
This incident affected: NCSI (Legacy) (Background Screenings) and SportsEngine Platform (Background Screening).