SportsSignUp Play: Performance Issues
Incident Report for SportsEngine
Resolved
The issues have been resolved.
Posted Apr 02, 2022 - 09:42 CDT
Monitoring
We are seeing performance return to normal; our team will continue to monitor.
Posted Apr 02, 2022 - 09:34 CDT
Investigating
At this time, you may experience issues with accessing your SportsSignUp Play website. Our team is actively engaged and investigating the issue to resolve as quickly as possible.
Posted Apr 02, 2022 - 09:29 CDT
This incident affected: SportsSignup Play.