Service Interruption: League Athletics
Incident Report for SportsEngine
Resolved
This incident has been resolved.
Posted Dec 25, 2020 - 23:51 CST
Investigating
Scope: Some League Athletics websites are unavailable.
Next Update: 30 minutes

We are currently investigating this issue.
Posted Dec 25, 2020 - 23:08 CST
This incident affected: League Athletics.