Verification is currently underway for the maintenance items.
Posted Aug 06, 2025 - 23:43 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 06, 2025 - 21:00 CDT
Scheduled
SportsEngine Motion (U.S. and U.K.) will undergo scheduled system maintenance on Wednesday, August 6, 2025, from 9:00 PM to 12:00 AM CDT. During this window, the application will be temporarily unavailable, and users will be redirected to a maintenance page.
We apologize for any inconvenience and appreciate your understanding as we work to improve your experience with the platform.