Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 13, 2024 - 07:00 CST
Scheduled
We will be performing planned maintenance to SportsEngine HQ on Wednesday, November 13, 2024 from 7:00am CT to 8:00am CT. During this maintenance window, we don't anticipate any impact to the platform.
Posted Nov 12, 2024 - 15:42 CST
This scheduled maintenance affected: SportsEngine HQ (Registration - programs and sign-ups, Website - front end CMS (Sitebuilder), Financials - invoicing, reporting, payment processing, Season Management - rostering, scheduling, location management, scoring, and stats, Mobile App - chat, team RSVPs, and scheduling, Members - profiles, communication, reporting, MySE - user profiles, log in, account settings, API - legacy integrations) and SportsEngine Integrations API.