NCSI (Background Screening): Service Interruption
Incident Report for SportsEngine
Resolved
The recent issues with background screens for NCSI (Legacy) users is now resolved, and maintenance has been completed.
Posted Jan 21, 2022 - 18:41 CST
Monitoring
We are beginning to see performance improvements; and our team will continue to monitor the performance of the platform.
Posted Jan 21, 2022 - 16:22 CST
Update
Due to this service interruption, we are temporarily bringing our NCSI server offline to undergo the scheduled maintenance and upgrades that were originally planned for Monday, January 24. We anticipate the maintenance will last a few hours, and the NCSI platform and background screening system will not be operational during this time.
Posted Jan 21, 2022 - 15:09 CST
Update
Our team is continuing to diligently work on the issue.
Posted Jan 21, 2022 - 14:32 CST
Identified
After further monitoring, we are beginning to see continued issues with background screens for NCSI (Legacy) customers. We apologize for any inconvenience this is causing for your operation.
Posted Jan 21, 2022 - 12:46 CST
This incident affected: NCSI (Legacy) (Background Screenings).