Degraded Performance: Clare Payments

Incident Report for SportsEngine

Resolved

Performance has returned to normal.
Posted Oct 13, 2022 - 15:18 CDT

Investigating

We have identified degraded performance with the Clare Payments platform, which may impact registration and invoicing for the SportsEngine platform.
Posted Oct 13, 2022 - 14:36 CDT
This incident affected: SportsEngine HQ (Registration - programs and sign-ups, Financials - invoicing, reporting, payment processing).