SportsEngine Play Service Interruption

Incident Report for SportsEngine

Resolved

We are seeing performance return to normal, and our team will continue to monitor the platform.
Posted Jul 18, 2025 - 16:16 CDT

Monitoring

A fix has been implemented and we are monitoring results.
Posted Jul 18, 2025 - 15:31 CDT

Identified

At this time, you may experience issues with the Sports Engine Play platform. We are diligently working on the issue and will have it resolved as quickly as possible.
Posted Jul 18, 2025 - 15:23 CDT
This incident affected: SportsEngine Play.