SportsEngine Season Management - Degraded Performance

Incident Report for SportsEngine

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 15:12 CDT

Investigating

We are currently investigating this issue.
Posted Sep 03, 2025 - 14:04 CDT
This incident affected: SportsEngine HQ (Season Management - rostering, scheduling, location management, scoring, and stats).