SportsEngine Payments and Registrations: Partial Outage

Incident Report for SportsEngine

Resolved

This incident has been resolved.
Posted Jul 19, 2023 - 08:39 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 18, 2023 - 20:33 CDT

Investigating

At this time, some Canadian customers are unable to complete payments during checkout of registration and invoices. US based organizations are unaffected. We are diligently working on the issue and will have it resolved as quickly as possible.
Posted Jul 18, 2023 - 13:43 CDT
This incident affected: SportsEngine HQ (Registration - programs and sign-ups, Financials - invoicing, reporting, payment processing).