We have resolved the issue with API responsiveness and are monitoring for full recovery.
Posted May 20, 2025 - 12:05 CDT
Update
We are continuing to investigate this issue.
Posted May 20, 2025 - 11:48 CDT
Investigating
We are currently investigating this issue.
Posted May 20, 2025 - 11:47 CDT
This incident affected: SportsEngine Integrations API and SportsEngine HQ (Season Management - rostering, scheduling, location management, scoring, and stats).