Degraded Functionality: BTS ScoreEntry
Incident Report for SportsEngine
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 02, 2019 - 13:02 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Mar 02, 2019 - 12:41 CST
Investigating
Scope: BTS ScoreEntry is not allowing meet administrators to enter scores.
Next Update: 30 minutes

We are currently investigating this issue.
Posted 3 months ago. Mar 02, 2019 - 11:45 CST
This incident affected: Beyond the Scores - BTS.