Performance Issues: Processing Payments via HQ
Incident Report for SportsEngine
Resolved
Performance has returned to normal.
Posted Nov 04, 2022 - 15:06 CDT
Investigating
At this time, you may experience some issues with processing payments via the SportsEngine HQ platform. Our team is actively working to resolve.
Posted Nov 04, 2022 - 14:36 CDT