The issue causing degraded performance has been resolved. Performance has returned to normal levels and we will continue to monitor the platform to ensure stability.
Posted Feb 25, 2026 - 10:33 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2026 - 10:19 CST
Investigating
We are currently experiencing degraded performance across SportsEngine. Some users may encounter slow load times or intermittent errors. We are working to restore normal service as quickly as possible.
Posted Feb 25, 2026 - 09:48 CST
This incident affected: SportsEngine HQ (Website - front end CMS (Sitebuilder)).